Programação e Desenvolvimento

Projetos, softwares, sites, blogs e trabalhos conforme sua necessidade e com os melhores preços.
Tecnologia do Blogger.

Text Widget

Search (Don't Edit)

Sample Text

Formulir Kontak

Nome

E-mail *

Mensagem *

Full-Width Version (true/false)

Flickr

Facebook

Translate

Video of the Day

Slider (Add Label Name Here!) (Documentation Required)

Teste Teste Teste

Know us

Teste Teste Teste Teste

Popular Posts

Featured

19 de set de 2017

Algoritmo em Visualg - O resultado será dizer, pelas idades crescentes, quem é o avô, quem é o filho e quem é o neto(a diferença entre elas deverá ser de, no mínimo, 20 anos)

Um programa no visualg(portugol) onde o usuário digitará três nomes do mesmo sexo e suas idades (a diferença entre elas deverá ser de, no mínimo, 20 anos). O resultado será dizer, pelas idades crescentes, quem é o avô, quem é o filho e quem é o neto.


algoritmo "semnome"
// Função :
// Autor :
// Data : 19/09/2017
// Seção de Declarações
var
      n1,n2,n3:caracter
      idade1, idade2, idade3, aux1, aux2, aux3, aux4, aux5, aux6, aux7, aux8, aux9, aux10, aux11, aux12:inteiro
inicio

    escreva("Informe o primeiro nome e idade? ")
    leia(n1)
    escreva("Informe a idade? ")
    leia(idade1)
     escreva("Informe o segundo nome ? ")
     leia(n2)
    repita
      escreva("Informe a idade? ")
      leia(idade2)
      aux1 <- idade1 - idade2
      aux2 <- idade2 - idade1
    ate (aux1 >= 20) ou (aux2 >= 20)

     escreva("Informe o terceiro nome? ")
    leia(n3)
    repita
      escreva("Informe a idade? ")
      leia(idade3)
      aux1 <- idade1 - idade3
      aux5 <- idade3 - idade2
      aux6 <- idade2 - idade1
      
      aux2 <- idade3 - idade1
      aux7 <- idade1 - idade2
      aux8 <- idade2 - idade3
      
      aux3 <- idade2 - idade3
      aux9 <- idade3 - idade1
      aux10 <- idade1 - idade2
      
      aux4 <- idade3 - idade2
      aux11 <- idade2 - idade1
      aux12 <- idade1 - idade3
      
    ate ((aux1 >= 20) e (aux5 >= 20))ou ((aux1 >= 20) e (aux6 >= 20))  ou ((aux2 >= 20) e (aux7 >= 20))ou ((aux2 >= 20) e (aux8 >= 20))  ou  ((aux3 >= 20) e (aux9 >= 20))ou ((aux3 >= 20) e (aux10 >= 20)) ou       ((aux4 >= 20) e (aux11 >= 20))ou ((aux4 >= 20) e (aux12 >= 20))
        
        
     se (idade1 < idade2) e (idade2 < idade3)  entao
           escreval("Filho: ",n1)
           escreval("Pai: ",n2)
          escreval("Avo: ",n3)
      senao
          se (idade1 < idade2) e (idade2 > idade3)  entao
          escreval("Filho: ",n1)
          escreval("Pai: ",n3)
          escreval("Avo: ",n2)
      senao
          se (idade1 > idade2) e (idade1 < idade3)  entao
          escreval("Filho: ",n2)
          escreval("Pai: ",n1)
          escreval("Avo: ",n3)
      senao
          se (idade1 > idade3) e (idade2 > idade1)  entao
          escreval("Filho: ",n3)
          escreval("Pai: ",n1)
          escreval("Avo: ",n2)
      senao
          se (idade1 > idade3) e (idade2 < idade3)  entao
          escreval("Filho: ",n2)
          escreval("Pai: ",n3)
          escreval("Avo: ",n1)
      senao
          se (idade1 > idade2) e (idade2 > idade3)  entao
          escreval("Filho: ",n3)
          escreval("Pai: ",n2)
          escreval("Avo: ",n1)

          fimse
          fimse
          fimse
          fimse
          fimse
          fimse

fimalgoritmo




←  Anterior Proxima  → Inicio

Postagem em destaque

MVF5 System - SOLUÇÕES EM TI!

          Desenvolvimento de projetos, softwares, sites, blogs e trabalhos conforme sua necessidade e com os melhores preços. Entre em c...

Seguidores

Total de visualizações

Postagens populares