Programação e Desenvolvimento

Projetos, softwares, sites, blogs e trabalhos conforme sua necessidade e com os melhores preços.
Tecnologia do Blogger.

Text Widget

Search (Don't Edit)

Sample Text

Formulir Kontak

Nome

E-mail *

Mensagem *

Full-Width Version (true/false)

Flickr

Facebook

Translate

Video of the Day

Slider (Add Label Name Here!) (Documentation Required)

Teste Teste Teste

Know us

Teste Teste Teste Teste

Popular Posts

Featured


30 de jun de 2014

Algoritmo em C - Ordenar Vetor

Algoritmo feito, que recebe os valores de um vetor, mostra o vetor preenchido normal, depois ordena de forma crescente e mostra na tela.

#include<stdio.h>
int main(){
    int numero[5],x,y,aux=0;
    for(x=0;x<5;x++){
       printf("%d - ",x+1);
       scanf("%d",&numero[x]);
       }
    //vetor normal
    printf("\n\nVetor\n");
    for(x=0;x<5;x++){
         printf("%d<- [%d] \n",x+1,numero[x]);
         }
    for(x=0;x<5;x++){
       for(y=0;y<5;y++){
          if(numero[y]>numero[y+1]){
             aux=numero[y];
             numero[y]=numero[y+1];
             numero[y+1]=aux;
             }
          }
       }
    //vetor em ordem
    printf("\n\n\nvetor em crescente\n");
    for(x=0;x<5;x++){
     printf("%d<- [%d] \n",x+1,numero[x]);
     }
    getche();
}

MVF5-System - Soluções em TI.
Tem algum projeto, software, sites, blog, trabalhos em geral.
Traga sua ideia que resolvemos.
Contatos para trabalho: mvf5system@gmail.com;





Algoritmo em C - Quantidade de vogais.

Um algoritmo em C, onde o usuário informar uma vogal qualquer 15 vezes. No final, exiba
a quantidade de cada vogal e de caracteres incorretos que ele informou.

#include<stdio.h>
int main(){
    int aux,a=0,e=0,i=0,o=0,u=0,errada=0;
    char letra;
    for(aux=0;aux<4;aux++){
       printf("informe uma vogal:\n");
       scanf("%c",&letra);
     
       if(letra=='a'||letra=='A')
          a++;
       else if(letra=='e'||letra=='E')
          e++;
       else if(letra=='i'||letra=='I')
          i++;
       else if(letra=='o'||letra=='O')
          o++;
       else if(letra=='u'||letra=='U')
          u++;
       else
        errada++;
        getchar();
        }
    printf("vogal A tem %d\n",a);
    printf("vogal E tem %d\n",e);
    printf("vogal I tem %d\n",i);
    printf("vagal O tem %d\n",o);
    printf("vogal U tem %d\n",u);
    printf("letra erradas tem %d\n",errada);
    getche();
}
 MVF5-System - Soluções em TI.
Tem algum projeto, software, sites, blog, trabalhos em geral.
Traga sua ideia que resolvemos.
Contatos para trabalho: mvf5system@gmail.com;

Algoritmo em C - Média das notas digitadas.

Um algoritmo em C, onde o usuário deverá informar 2 notas de 10 alunos, e no final , exiba qual a ordem e a média dos alunos que tiveram a maior e a menor média.


#include<stdio.h>
int main(){
    int n1,n2,aux,aluno=0,ordmaior,ordmenor;
    float medmaior,medmenor;
    for(aux=0;aux<10;aux++){
    aluno++;
       do{
         printf("informe a primeira nota do aluno (%d)",aluno);
         scanf("%d",&n1);
         if(n1<0||n1>10)
         printf("nota invalida, informe uma nota correta\n");
         system("pause");
         system("cls");
        }while(n1<0||n1>10);
       do{
         printf("informe a segunda nota do aluno (%d)",aluno);
         scanf("%d",&n2);
         if(n2<0||n2>10)
         printf("nota invalida, informe umanota valida\n");
         system("pause");
         system("cls");        
         }while(n2<0||n2>10);
    
    if(aux==0){
      medmaior=(n1+n2)/2;
      medmenor=medmaior;
      ordmaior=aux+1;
      ordmenor=aux+1;
      }
      else if((n1+n2)/2>medmaior){
           medmaior=(n1+n2)/2;
           ordmaior=aux+1;
           }
      else if((n1+n2)/2<medmenor){
           medmenor=(n1+n2)/2;
           ordmenor=aux+1;
           }
     }
     printf("o melhor aluno foi %d\n",ordmaior);
     printf("a melhor media foi %.2f\n",medmaior);
     printf("o pior aluno foi %d\n",ordmenor);
     printf("a media do pior aluno foi %.2f\n",medmenor);
    getche();
}


MVF5-System - Soluções em TI.
Tem algum projeto, software, sites, blog, trabalhos em geral.
Traga sua ideia que resolvemos. 
Contatos para trabalho: mvf5system@gmail.com;


Algoritmo em C - fatorial de um número dado

Algoritmo em C, que calcule o fatorial de um número dado, pelo usuário.

#include <stdio.h>
int main(){
    int num, cont, fat=1;
    printf("Digite o numero: \n");
    scanf("%d", &num);
    for(cont=1; cont <= num; cont++){
    fat *= cont;
    }

    printf("\nO fatorial de %d e: %d",num,fat);

    getche();

}

MVF5-System - Soluções em TI.
Tem algum projeto, software, sites, blog, trabalhos em geral.
Traga sua ideia que resolvemos. 
Contatos para trabalho: mvf5system@gmail.com;


29 de jun de 2014

Algoritmo em Visualg - Ordenar um Vetor

Algoritmo feito em Visualg que preencher um vetor depois vai ordenar.

algoritmo "ordenar_Vetor"
// Função :  vai preencher um vetor depois vai ordenar
// Autor :   marcos vinicius
// Data :
// Seção de Declarações
var
   vet:vetor[1..5]de inteiro
   aux,x,i:inteiro
inicio
// Seção de Comandos
   para x de 1 ate 5 passo 1 faca
        escreva("informe um numero")
        leia(vet[x])
   fimpara
   aux<-0
         para i de 1 ate 5 passo 1 faca
             para x de 1 ate 4 passo 1 faca
                  se(vet[x] > vet[x+1])ENTAO
                       aux<-vet[x]
                       vet[x]<-vet[x+1]
                       vet[x+1]<-aux
                  fimse
             fimpara
         fimpara
     para x de 1 ate 5 passo 1 faca
          escreval(vet[x])
     fimpara
fimalgoritmo

MVF5-System - Soluções em TI.
Tem algum projeto, software, sites, blog, trabalhos em geral.
Traga sua ideia que resolvemos. 
Contatos para trabalho: mvf5system@gmail.com;

Algoritmo em Visualg - Exemplo de função.

Algoritmo em Visualg que mostra um exemplo de uma função.
Uma função que recebe dois números inteiros, retorna a soma!

algoritmo "EX_funcao"
// Função : ex de função
// Autor :  marcos vinicius
// Data :
// Seção de Declarações
   funcao soma(num1:inteiro;num2:inteiro):inteiro
      var
       s:inteiro
   inicio
         s<- num1+num2
         retorne s
   fimfuncao
var
   n1,n2,soma_res:inteiro

inicio
      escreva("escreva os valores a serem somados")
      leia(n1,n2)
      soma_res<-soma(n1,n2)
      escreva("a soma e ",soma_res )
fimalgoritmo


Algoritmo em Visualg - fibonacci

Algoritmo em Visualg em faz as 30 primeiras posições da função do Fibonacci, e armazena num vetor e mostra no final.

 algoritmo "fibonacci"
// Função : Função do fibonacci
// Autor : Marcos Vinicius
// Data : 
// Seção de Declarações 
var
   fibo:vetor[1..30]de inteiro   
   anterior,atual,posterior,aux:inteiro
inicio
// Seção de Comandos
   atual<-1
   anterior<-0
   posterior<-0
   para aux de 1 ate 30 passo 1 FACA
        posterior<-atual+anterior
        fibo[aux]<-atual        
        anterior<-atual
        atual<-posterior

   fimpara
   para aux de 1 ate 30 passo 1 FACA
        escreva(fibo[aux])       
   fimpara
   
fimalgoritmo

MVF5-System - Soluções em TI.
Tem algum projeto, software, sites, blog, trabalhos em geral.
Traga sua ideia que resolvemos. 
Contatos para trabalho: mvf5system@gmail.com;

Algoritmo em C - conversão de Fahrenheit.

Um programa que receba a temperatura local em grau Fahrenheit e converta em Celsius.

#include<stdio.h>
int main(){
    int f;
    float c;
    printf("informe a temperatura em Fahrenheit");
    scanf("%d",&f);
    c=(f-32)/1.8;
    printf("\n temperatura em Celsius: %.2f",c);
    getche();
}

MVF5-System - Soluções em TI.
Tem algum projeto, software, sites, blog, trabalhos em geral.
Traga sua ideia que resolvemos. 
Contatos para trabalho: mvf5system@gmail.com;

Algoritmo em java - Calculadora.

Algoritmo em java, que recebe uma opção, (+, -, *, /, 0 - sair), e dois números, e faz a operação de acordo com a opção informada, e na opção da divisão não deixando fazer a divisão por Zero.

Duvidas deixe nos comentários.

import javax.swing.JOptionPane;

public class Principal {
    
    public static void main(String[] args) {
       String op;
       float num1, num2;
       do{
            op = JOptionPane.showInputDialog("[ + ] - somar\n"+
                                            "[ -  ] - subtrair\n"+
                                            "[ * ] - multiplicar\n"+
                                            "[ /  ] - dividir\n"+
                                            "[ 0 ] - sair");
            switch(op){
                  case "+":
                           try{
                               num1 = Float.parseFloat(JOptionPane.showInputDialog("Informe 1º numero: "));
                               num2 = Float.parseFloat(JOptionPane.showInputDialog("Informe 2º numero: "));
                              JOptionPane.showMessageDialog(null, "Soma: " +(num1 + num2));
                          }catch(Exception e){
                             JOptionPane.showMessageDialog(null, "Erro: ");

                          }
                  break;
                  case "-":
                          try{
                              num1 = Float.parseFloat(JOptionPane.showInputDialog("Informe 1º numero: "));
                              num2 = Float.parseFloat(JOptionPane.showInputDialog("Informe 2º numero: "));
                             JOptionPane.showMessageDialog(null, "Subtração: " +(num1 - num2));
                        }catch(Exception e){
                            JOptionPane.showMessageDialog(null, "Erro: ");
                       }
                break;
                case "*":
                   try{
                        num1 = Float.parseFloat(JOptionPane.showInputDialog("Informe 1º numero: "));
                        num2 = Float.parseFloat(JOptionPane.showInputDialog("Informe 2º numero: "));
                        JOptionPane.showMessageDialog(null, "Multiplicão: " +(num1 * num2));
                   }catch(Exception e){
                        JOptionPane.showMessageDialog(null, "Erro: ");
                   }
               break;
               case "/":
                   try{
                        num1 = Float.parseFloat(JOptionPane.showInputDialog("Informe 1º numero: "));
                        do{
                            num2 = Float.parseFloat(JOptionPane.showInputDialog("Informe 2º numero: "));
                            if(num2 == 0){
                                JOptionPane.showMessageDialog(null, "Não existe Divisão por 0");
                            }
                        }while(num2 == 0);
                        JOptionPane.showMessageDialog(null, "Divisão: " +(num1 / num2));
                   }catch(Exception e){
                        JOptionPane.showMessageDialog(null, "Erro: ");
                   }
               break;
               case "0": break;
               default:
                   JOptionPane.showMessageDialog(null, "Caracter invalida!");
           }
       }while(!(op.equals("0")));
    }
}






Algoritmo em Visualg - Somatório dos fatoriais.

Um algoritmo em Visualg, que receba 15 valores numéricos inteiros, faz-se os fatoriais de cada número e apresente e no final apresente o somatório dos fatoriais.

Dúvidas deixe nos comentários.

algoritmo "Somatório dos fatoriais"
// Função : recebe valores, mostra os fatorial de cada número e no final faz a soma deles.
// Autor : Marcos Vinicius
// Data : 
// Seção de Declarações
var
   fat,cont,soma,n, x, y:inteiro
   valor:inteiro
inicio
// Seção de Comandos
    soma<- 1
    valor<- 0
     n <- 0
     para x de 1 ate 15 passo 1 faca
          escreval("insira um numero:",x)
          leia(n)
          soma <- 1
          para y de n ate 1 passo -1 faca

               soma<-soma*y;
          fimpara
          escreval("fatorial ",soma)
          valor <- valor + soma
     fimpara
     escreval("----------------------------------------------------")

     escreval("A soma dos fatoriais: ",valor)
fimalgoritmo


MVF5-System - Soluções em TI.
Tem algum projeto, software, sites, blog, trabalhos em geral.
Traga sua ideia que resolvemos. 
Contatos para trabalho: mvf5system@gmail.com;



Algoritmo em Visualg - Converter número decimal em Hexadecimal

Algoritmo em Visualg para conversão de números decimal em Hexadecimal.

 1 - O número a ser convertido não poderá ultrapassar de 5 dígitos.
 2 - Algoritmo não pode aceitar números negativos.
 3 - Cada etapa da conversão deve ser exibida, ou seja, cada resto da divisão e cada quociente devem ser          mostrados para cada etapa.
4 - Caso o numero convertido não seja suficientemente grande para preencher todo o vetor preencha os             espaços vazios com o numero Zero.
5 - Exibe o seguinte menu:

  1. Converter Número
  2. Sair.
Dúvidas deixe nos comentários.

algoritmo "Conversão em Hexadecimal"
// Função :  Converter número decimal em Hexadecimal
// Autor :   Marcos vinicius
// Data : 
// Seção de Declarações
var
   tabela: vetor[0..15] de caracter
   h: vetor[0..5] de caracter
   aux: vetor[0..5] de caracter
   op,num, cont,i:inteiro
   hexad: caracter
   resto: inteiro

inicio
        tabela[0]<- "0"
        tabela[1]<- "1"
        tabela[2]<- "2"
        tabela[3]<- "3"
        tabela[4]<- "4"
        tabela[5]<- "5"
        tabela[6]<- "6"
        tabela[7]<- "7"
        tabela[8]<- "8"
        tabela[9]<- "9"
        tabela[10]<- "A"
        tabela[11]<- "B"
        tabela[12]<- "C"
        tabela[13]<- "D"
        tabela[14]<- "E"
        tabela[15]<- "F"

      repita
         escreval("1 converter numero:")
         escreval("0 sair")
         escreval("sua opção:")
         leia (op)

         escolha op
         caso 1
            hexad<-""
            cont<-0
            escreval("dite um numero:")
            leia(num)
            escreval("-------------------------------")
            se (num <= 99999) e (num >=0)entao
               enquanto num>0 faca
                  escreval("Quociente: ",num)
                  resto<- (num mod 16)
                  num<- (num \ 16)
                  hexad<- tabela[resto]+hexad
                  h[cont]<- tabela[resto]+h[cont]
                  cont<-cont + 1
                  escreval("Resto da divisao: ",resto)
               fimenquanto
               escreval("---------------------------")
               cont<-0
                 para i de 0 ate 5 passo 1 faca
                    se(h[5-i]<>"")entao
                      aux[cont]<-h[5-i]
                      cont<-cont + 1
                    fimse
                fimpara
                escreva("Vetor: ")
                para i de 0 ate 5 passo 1 faca
                se(aux[i]="")entao
                  aux[i]<-"0"
                fimse
                 escreva(aux[i])
                 h[i]<- ""
                 aux[i]<- ""
                fimpara
                escreval()
               escreval("Hexadecimal: ", hexad)
            senao
                 escreval("numero invalido!")
            fimse

         caso 0
            escreval("sair")
         outrocaso
            escreval("opção invalida:")
         fimescolha
      ate op = 0

fimalgoritmo


Precisando de ajuda, entre em contato: https://mvf5-system.blogspot.com.br/2016/11/mvf5-system-solucoes-em-ti.html

28 de jun de 2014

Algoritmo em C - calcule a soma dos 100 primeiros números inteiros.

Um Algoritmo que calcule a soma dos 100 primeiros números inteiros, em C.










MVF5-System - Soluções em TI.
Tem algum projeto, software, sites, blog, trabalhos em geral..
Traga sua ideia que resolvemos.
Contatos para trabalho: mvf5system@gmail.com;

Algoritmo em C - números primos

Escreva um Algoritmo em C, que apresente os N primeiros números primos a partir do número 2 para um valor n>0 fornecido pelo usuário.


Dúvidas deixe nos comentários.
#include<stdio.h>
int main(){
    int x,n,i,cont=0, aux = 0;
    do{
    printf("informe um numero");
    scanf("%d",&n);
    }while(n <= 0);  
    i = 2;
    do{    
       for (x=1;x<=i;x++){
          if (i%x== 0){
       cont++;
     }
       }  
   
        if (cont == 2){
        printf("o numero %d ", i);
        printf("eh primo\n");
        aux++;
        }      
       i++;    
       cont = 0;
    }while(aux < n);
     
   getche();
}

MVF5-System - Soluções em TI.
Tem algum projeto, software, sites, blog, trabalhos em geral.
Traga sua ideia que resolvemos.
Contatos para trabalho: mvf5system@gmail.com;

←  Anterior Inicio

Postagem em destaque

MVF5 System - SOLUÇÕES EM TI!

          Desenvolvimento de projetos, softwares, sites, blogs e trabalhos conforme sua necessidade e com os melhores preços. Entre em c...

Seguidores

Total de visualizações

Postagens populares